Gallery

Gallery.

R Interpreter

R Interpreter

Datalayer Sptifire extends the R interpreter support of the open source Apache Zeppelin notebook project.

Prerequisite

You need R available on the host running the notebook.

Install additional R packages:

curl https://cran.r-project.org/src/contrib/Archive/rscala/rscala_1.0.6.tar.gz -o /tmp/rscala_1.0.6.tar.gz
R CMD INSTALL /tmp/rscala_1.0.6.tar.gz
R -e "install.packages('ggplot2', repos = 'http://cran.us.r-project.org')"
R -e "install.packages('knitr', repos = 'http://cran.us.r-project.org')"
R -e "install.packages(c('devtools','mplot', 'googleVis'), repos = 'http://cran.us.r-project.org'); require(devtools); install_github('ramnathv/rCharts')"

You also need a compiled version of Spark 1.5.0. Download the binary distribution and untar to make it accessible in /opt/spark folder.

Simple R

Simple R

Ggplot2

ggplot2

RCharts

rcharts

maps

GoogleVis

googlevis

Scala R Binding

Scala R Binding

Scala R Dataframe Binding

R Scala Binding

R Scala Binding

SparkR

SparkR